03.11.2025

9845

# № 9845 Основная волна 27.06.23 (Уровень: Базовый)
# Текстовый файл состоит из символов, обозначающих буквы латинского алфавита А, В и С и цифры 8 и 9.
# Определите в прилагаемом файле максимальное количество идущих подряд символов, среди которых ни
# одна буква не стоит рядом с буквой, а цифра — с цифрой.

f=open("24_9845.txt")
st=f.readline()
# st = "ABCC8CC8CC9C9A8AAAA89CC8C9A"

st = st.replace("A", "*")
st = st.replace("B", "*")
st = st.replace("C", "*")

st = st.replace("8", "!")
st = st.replace("9", "!")


counter = 1
m = 0
for i in range(0, len(st)-1):
    if st[i] != st[i+1]:
        counter += 1
        if counter > m:
            m = counter
    else:
        counter = 1

print(m)