01.11.2025

17_11236

# В файле содержится последовательность целых чисел, каждое из которых по
# модулю не превышает 100 000. Определите количество троек элементов
# последовательности, в которых ровно два из трёх элементов больше квадрата
# минимального двузначного элемента последовательности, а произведение модулей
# элементов тройки кратно максимальному четырёхзначному элементу последовательности,
# который оканчивается на 1.  В ответе запишите количество
# найденных троек чисел, затем максимальную из сумм модулей элементов таких троек.

mas=list(map(int,open("17_11236.txt").readlines()))

min_dv_znach = 10000000
for i in range(len(mas)):
    if len(str(abs(mas[i])))==2:
        if mas[i]<min_dv_znach:
            min_dv_znach=mas[i]
print(min_dv_znach)

max_4_1 = -100000000
for i in range(len(mas)):
    if len(str(abs(mas[i])))==4 and str(mas[i])[-1]=="1":
        max_4_1=max(mas[i],max_4_1)

print(max_4_1)

inogK=0
Maxim=-10000000
for i in range(len(mas)-2):
    k=0
    if mas[i]>min_dv_znach**2:
        k+=1
    if mas[i+1]>min_dv_znach**2:
        k+=1
    if mas[i+2]>min_dv_znach**2:
        k+=1
    if k==2:
        if (abs(mas[i])*abs(mas[i+1])*abs(mas[i+2]))%max_4_1==0:
            inogK+=1
            if (abs(mas[i])+abs(mas[i+1])+abs(mas[i+2]))>Maxim:
                Maxim=(abs(mas[i])+abs(mas[i+1])+abs(mas[i+2]))

print(inogK,Maxim)