01.11.2025

5_13874 

# На вход алгоритма подаётся нечётное натуральное число N
# 1. Строится четверичная запись числа N.
# 2. Далее эта запись обрабатывается по следующему правилу:
# а) если число N делится на 3, то первая и последняя цифры меняются местами, а затем в конец дописывается единица;
# б) если число N на 3 не делится, то остаток от деления на 3 дописывается в конец числа.
# Полученная таким образом запись является четверичной записью искомого числа R.
# 3. Результат переводится в десятичную систему и выводится на экран.
# Например, для исходного числа 11 = 234 результатом является число 2324= 46, а для исходного числа 13 = 314 это число 3114 = 53.
# Укажите максимальное число R, не превышающее 340, которое может быть получено с помощью описанного алгоритма.
print("Васо"[-2])

def chet (n):
    s=""
    while(n>0):
        z = n%4
        n=n//4
        s+=str(z)
    return s[::-1]

m=[]
for N in range(1,10001,2):
    s = chet(N)
    if N%3==0:
        s1 = s[0]
        s2 = s[-1]
        s3 = s[1:-1]
        s = s2 + s3 + s1
        s += '1'
    else:
        s+= str(N%3)
    r=int(s,4)
    if r<=340:
        m.append(r)
print(max(m))