02.11.2025

24_17535 

# Текстовый файл состоит из символов A, B, C, D, E и F.
# Определите максимальное количество идущих подряд символов в прилагаемом файле,
# среди которых пара символов CD (в указанном порядке) встречается ровно 160 раз.

f = open("24_17535.txt").readline()
print(f[:2:])
print(f[-3::])
f=f.split("CD")

# f = "000**0*00*0*0*".split("*")
n = 160
ma=0
# print("string ",f)
maxlen = 0
for i in range(0, len(f)-n):
    s=f[i:i+n+1]
    # print(s)
    newS="CD".join(s)
    # print(newS)
    ma=max(len(newS),ma)
print(ma+2) # т.к. CD не стоит в начале или конце строки