03.11.2025

(№ 1041) Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 3. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – максимальное число, оканчивающееся на 3.

n = int(input("Введите кол-во чисел"))
m = 0
for a in range(n):
    b = int(input())
    if b % 10 == 3:
        if b > m:
            m = b
print(m)