02.11.2025

8-234

# Вася составляет слова из букв слова АКАДЕМИК. Код должен состоять из 8 букв,
# и каждая буква в нём должна встречаться столько же раз, сколько в заданном слове.
# Кроме того, в коде не должны стоять рядом две гласные и две согласные буквы.
# Сколько различных слов может составить Вася?

from itertools import *

s = 'АДЕМИК'

k = 0

for i in product(s, repeat=8):
    a = "".join(i)
    if a.count("А") == 2 and a.count("К") == 2 and \
            a.count("Д") == 1 and a.count("Е") == 1 and a.count("М") == 1 and a.count("И") == 1:
        print(a)
        a = a.replace("А", "1")
        a = a.replace("К", "2")
        a = a.replace("Д", "2")
        a = a.replace("Е", "1")
        a = a.replace("М", "2")
        a = a.replace("И", "1")
        if("11" not in a) and ("22" not in a):
            k+=1

print(k)