02.11.2025

Пример решения задач раздела 5 ЕГЭ. № 80

#     80) Автомат получает на вход четырёхзначное число. По этому числу
#     строится новое число по следующим правилам:
# 1. Складываются первая и последняя, а также вторая и третья цифры исходного числа.
# 2. Полученные два числа записываются друг за другом в порядке возрастания
#     (без разделителей).
# Пример. Исходное число: 2357. Суммы: 2 + 7 = 9; 3 + 5 = 8. Результат: 89.
# Укажите наибольшее число, в результате обработки которого автомат выдаст число 815.

for n in range(1000,9999+1):
    s=str(n)
    s1=int(s[0])+int(s[3])
    # print(s1)
    s2=int(s[1])+int(s[2])
    # print(s2)

    mas=[s1,s2]
    # print(mas)
    mas=sorted(mas) # по возрастанию
    # mas=sorted(mas, reverse=True) # это по убыванию
    # print(mas)

    r=str(mas[0])+str(mas[1])
    # print(r)
    if int(r)==815:
        print(n)