02.11.2025

Поляков 5 — 68

    68) Автомат получает на вход трёхзначное число. По этому числу строится новое
число по следующим правилам.
1. Складываются первая и вторая, а также вторая и третья цифры исходного числа.
2. Полученные два числа записываются друг за другом в порядке убывания (без разделителей).
Пример. Исходное число: 348. Суммы: 3 + 4 = 7; 4 + 8 = 12. Результат: 127.
Укажите наибольшее число, в результате обработки которого автомат выдаст число 1513.



for n in range(100,999+1):
    n=str(n)
    a=n[0]
    b=n[1]
    c=n[2]
    s1=int(a)+int(b)
    s2=int(b)+int(c)
    # print(s1,s2)
    massiv=[s1,s2]
    massiv=sorted(massiv,reverse=True)
    # print(massiv)
    rez=str(massiv[0])+str(massiv[1])
    # print(rez)
    if int(rez)==1513:
        print(n)