02.11.2025

Поляков егэ 5 — 116

    116) Автомат получает на вход четырёхзначное натуральное число и строит новое число по следующему алгоритму:
1. вычисляются суммы первой и второй, второй и третьей и третьей и четвёртой цифр;
2. из полученных сумм отбрасывается наименьшая;
3. остальные суммы записываются в порядке невозрастания.
Пример. Исходное число:1284. Суммы: 1 + 2 = 3; 2 + 8 = 10; 8 + 4 = 12. Отбрасывается наименьшая сумма 3. Результат: 1210. Укажите наименьшее число, при вводе которого автомат выдаёт значение 139.


for n in range(1000,9999+1):
    n=str(n)
    a=n[0]
    b=n[1]
    c=n[2]
    d=n[3]
    # print(a,b,c,d)
    s1=int(a)+int(b)
    s2=int(b)+int(c)
    s3=int(c)+int(d)
    # print(s1,s2,s3)
    mas=[s1,s2,s3]
    mas=sorted(mas,reverse=True)
    # print(mas)
    
    # Это лишнее, но интересное
    mas.pop(2) # удаление элемента по индексу
    # print(mas)
    
    rez=str(mas[0])+str(mas[1])
    # print(rez)
    if int(rez)==139:
        print(n)