02.11.2025

Поляков 5 — 102

#     102) Автомат получает на вход натуральное число X. По этому числу
#     строится трёхзначное число Y по следующим правилам.
# 1. Первая цифра числа Y (разряд сотен) – остаток от деления X на 4.
# 2. Вторая цифра числа Y (разряд десятков) – остаток от деления X на 2.
# 3. Третья цифра числа Y (разряд единиц) – остаток от деления X на 3.
# Пример. Исходное число: 55. Остаток от деления на 4 равен 3; остаток от
#     деления на 2 равен 1; остаток от деления на 3 равен 1. Результат работы
#     автомата: 311.
# Укажите наименьшее двузначное число, при обработке которого автомат выдаёт
#     результат 311.
for n in range(1,1000):
    a = n%4
    b= n%2
    c = n%3
    k = str(a)+ str(b)+ str(c)
    if int(k) == 311:
        print(n)