02.11.2025

Поляков 5 — 281

    281) На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом.
1. Вычисляется сумма S1 всех чётных цифр десятичной записи числа N. Если чётных цифр нет, сумма S1 считается равной 0.
2. Вычисляется сумма S2 всех цифр десятичной записи числа N, стоящих в чётных разрядах. Разряды нумеруются справа налево, начиная с 0. 
3. Вычисляется результат R как модуль разности S1 и S2.
Пример: Дано число N = 4321. С	умма чётных цифр S1 = 4 + 2 = 6. Сумма цифр в чётных разрядах S2 = 3 + 1 = 4. Результат работы алгоритма R = 6 – 4 = 2.
Укажите наименьшее число, в результате обработки которого по данному алгоритму получится число 26.


for n in range(1000000,2000000):
    x = str(n)
    summ_chet = 0
    for i in range(len(x)):
        if int(x[i])%2 ==0:
            summ_chet = summ_chet + int(x[i])
    # Вычисляется сумма S2 всех цифр десятичной записи числа N,
    # стоящих в чётных разрядах. Разряды нумеруются справа налево, начиная с 0.print(str[::-1])
    a = x[::-1]
    c = 0
    for b in range(len(a)):
        if b%2==0:
            c = c + int(a[b])

    r = abs(summ_chet-c)
    if r == 26:
        print(x)