03.11.2025

309) (В. Шелудько) Значение арифметического выражения 103∙7103 – 5∙757 + 98 записали в системе
счисления с основанием 7. Найдите сумму цифр получившегося числа и запишите её в ответе в десятичной
системе счисления.

n = 103*7**103 - 5*7**57 + 98
otvet = 0

while n>0:
    ost = n%7
    n = n//7
    otvet += ost
    
    
print(otvet)

Добавить комментарий