03.11.2025

Поляков Егэ 17 №34

# 34)	(А. Куканова) Рассматривается множество целых чисел, принадлежащих числовому отрезку [1000; 9999], которые удовлетворяют следующим условиям:
# − не делятся нацело на 3, 17 и 19;
# − запись в четверичной системе счисления имеет ровно 6 цифр.
# Найдите минимальное и максимальное из этих чисел.
maxim=0
minim=1000000
for n in range(1000,9999+1):
    if n%3!=0 and n%17!=0 and n%19!=0:
        if n>=int('100000',4) and n<=int('333333',4):
            if n>maxim:
                maxim=n
            if n<minim:
                minim=n
print(minim,maxim)

Добавить комментарий