02.11.2025

Поляков р5 №83

#     83) Автомат получает на вход трёхзначное число. По этому числу строится новое число по следующим правилам.
# 1. Складываются первая и вторая, а также вторая и третья цифры исходного числа.
# 2. Полученные два числа записываются друг за другом в порядке возрастания (без разделителей).
# Пример. Исходное число: 348. Суммы: 3+4 = 7; 4+8 = 12. Результат: 712.
# Укажите наименьшее число, в результате обработки которого автомат выдаст число 1115.

for N in range(100,1000):
    n=str(N)
    s1=int(n[0])+int(n[1])
    # print(s1)
    s2=int(n[1])+int(n[2])
    # print(s2)
    m=[]
    m.append(s1)
    m.append(s2)
    r=sorted(m)
    r=str(m[0])+str(m[1])
    if r=='1115':
        print(N)

Добавить комментарий