03.11.2025

Поляков р5 № 66

'''    66) Автомат получает на вход трёхзначное число. По этому числу строится новое
число по следующим правилам.
1. Складываются первая и вторая, а также вторая и третья цифры исходного числа.
2. Полученные два числа записываются друг за другом в порядке убывания (без разделителей).
Пример. Исходное число: 348. Суммы: 3 + 4 = 7; 4 + 8 = 12. Результат: 127.
Укажите наименьшее число, в результате обработки которого автомат выдаст число 1412.'''

for n in range(100,1000):
    N=str(n)
    N1=int(N[0])+int(N[1])
    #print(N1)
    N2=int(N[1])+int(N[2])
    #print(N2)
    mas=[N1,N2]
    #print(mas)
    mas=sorted(mas, reverse=True) # сортировка. параметр reverse устанавливает порядок сортировки
    #print(mas)
    r=int(str(mas[0])+str(mas[1]))
    #print(r)
    if r==1412:
        print(n)

Добавить комментарий