02.11.2025

Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое двузначных чисел или сообщает, что таких чисел нет. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести среднее арифметическое двузначных чисел или вывести NO, если таких чисел в последовательности нет.

s=0
k=0
for i in range(100):
    a=int(input("Введите число "))
    if a==0:
        break
    if a>9 and a<100:
        s=s+a
        k=k+1
if k==0:
    print("NO")
else:
print(s/k)
    

Добавить комментарий