03.11.2025

(№ 1013) Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое трёхзначных чисел или сообщает, что таких чисел нет (выводит NO). Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести среднее арифметическое трёхзначных чисел или вывести NO, если таких чисел нет.

k=0
n=0
for i in range (100):
    a=int(input())
    if a==0:
        break
    if a>99 and a<1000:
        k+=1 #счётчик
        n+=a #сумма
if k!=0:
    print(n/k)
else:
    print("NO")

Добавить комментарий