02.11.2025

5-79

#     79) Автомат получает на вход четырёхзначное число. По этому числу строится новое число
#     по следующим правилам:
# 1. Складываются первая и вторая, а также третья и четвёртая цифры исходного числа.
# 2. Полученные два числа записываются друг за другом в порядке возрастания (без разделителей).
# Пример. Исходное число: 2366. Суммы: 2 + 3 = 5; 6 + 6 = 12. Результат: 512.
# Укажите наибольшее число, в результате обработки которого автомат выдаст число 117.
maxim = 0
for N in range(1000, 9999 + 1):
    n = str(N)
    s1 = int(n[0]) + int(n[1])
    s2 = int(n[2]) + int(n[3])
    if s1 > s2:
        n = str(s2) + str(s1)
    else:
        n = str(s1) + str(s2)
    n = int(n)
    if n == 117:
        if N > maxim:
            maxim = N
print(maxim)

Добавить комментарий