02.11.2025

Поляков 17-375 (доделать)

def sss (n):
    mas = []
    for i in range(len(str(n))):
        g = n%10
        mas.append(g)
        n = n//10
    mas = mas[::-1]
    s = set(mas)
    if len(mas)==len(s):
        return(True)
    else:
        return(False)
print(sss(12345))


# В файле 17-375.txt содержится последовательность натуральных чисел,
# не превышающих 100000.  Определите количество симметричных пар последовательности,
# произведение элементов которых кратно минимальному трехзначному элементу
# последовательности, все цифры которого различны. В данной задаче под симметричной
# парой подразумеваются элементы, равноудаленные от центра последовательности.
# Например, для последовательности (1,2,3,4,5,6) таких пар будет три:
# (1,6) (2,5) (3,4). В ответе запишите количество найденных пар, затем
# минимальную из сумм элементов таких пар.
FileOpen = open('17-375.txt')
mas = list(map(int, FileOpen.readlines()))
mass = []
for m in range(len(mas)):
    if sss(m) == True and 100<=m<=999:
        mass.append(m)
H = min(mass)
k = 0
for I in range(len(mas)//2):
    if (mas[I] * mas[-1-I]) % H == 0:
        k += 1
print(k)