02.11.2025

Напишите программу, которая заполняет массив из 20 элементов случайными целыми числами на отрезке [100; 1000]и находит отдельно сумму элементов в первой и во второй половинах массива.

import random

# print(random.randint(100,1001))
a = 0
sum = 0

mas = []
for i in range(20):
    mas.append(random.randint(100, 1001))  # добавление 20 эл массива
print(mas)

for i in range(10):
    sum = sum + mas[i] # сумма первой половины
print(sum)

for i in range(10, 20):
    a = a + mas[i]     # сумма второй половины
print(a)