03.11.2025

Программа получает на вход число проехавших автомобилей N (1 ≤ N ≤ 30), затем указываются их скорости. Значение скорости не может быть меньше 1 и больше 300. Программа должна сначала вывести разность максимальной и минимальной скоростей автомобилей, затем количество автомобилей, скорость которых не превышала 30 км/ч.

k=0
max=-1000
min=1000
n=int(input("введите число больше 1 и меньше 30: "))
for i in range(n):
    v=int(input("введите скорость больше 1 и меньше 300: "))
    if v>max:
        max=v
    if v<min:
        min=v
    if v<=30:
        k+=1
print(max-min,k)

Добавить комментарий