03.11.2025

Напишите программу, которая в последовательности целых чисел определяет количество двузначных чисел, кратных 8. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число: количество двузначных чисел, кратных 8. РЕШЕНИЕ ПРИ ПОМОЩИ МАССИВА

mas=[]
for i in range(1000):
    a=int(input())
    if a==0:
        break
    else:
        mas.append(a)

s=0
for i in range(len(mas)):
    if mas[i] > 9 and mas[i] < 100 and mas[i]%8==0:
        s+=1
print(s)