02.11.2025

Поляков 25 — 8

# Напишите программу, которая ищет среди целых чисел, принадлежащих числовому отрезку
# [222987; 223021], числа, имеющие ровно 4 различных делителя. Выведите эти четыре делителя
# для каждого найденного числа в порядке возрастания.
from datetime import datetime

for n in range(222987, 223021+1):
    mas = set()
    for i in range(1, int(n ** 0.5) + 1):
        if n % i == 0:
            mas.add(i)
            mas.add(n // i)
        if len(mas)>=5:
            break
    if len(mas)==4:
        print(n,sorted(mas))