02.11.2025

Поляков 25 — 59

# Напишите программу, которая ищет среди целых чисел, принадлежащих числовому
# отрезку [7178551; 7178659], простые числа. Выведите все найденные простые числа
# в порядке возрастания, слева от каждого числа выведите его номер по порядку.

def issimple(n):
    for i in range(2, int(n**0.5)+1):
        if n % i == 0:
            return False
    return True

for n in range(7178551, 7178660):
    if issimple(n) == True:
        print(n)