26.04.2025

8-42588

# Вася составляет 6-буквенные слова, в которых могут быть использованы
# только буквы Л, Е, Г, К, О, причём буква О используется не более одного раза.
# Каждая из других допустимых букв может встречаться в слове любое количество раз
# или не встречаться совсем. Слово не должно начинаться с буквы Г и оканчиваться
# гласными буквами. Словом считается любая допустимая последовательность букв,
# не обязательно осмысленная. Сколько существует таких слов, которые может написать Вася?
from itertools import *
str="легко"
gl = 'ео'
k = 0
for i in product(str,repeat=6):
    s="".join(i)
    if s.count('о') <= 1 and s[0] != 'г' and s[5] not in gl:
        k += 1
print(k)