02.11.2025

8-6477

# Гарри решил составлять слова с помощью перестановки букв в слове «ЛЕВИОСА».
# Слово не может начинаться с гласной, а в центре не может стоять согласная буква.
# Словом считается любая допустимая последовательность букв, не обязательно осмысленная.
# Сколько слов может составить Гарри?
from itertools import *

str="левиоса"
gl="еиоа"
sgl="лвс"
k=0
for i in permutations(str,7):
    s="".join(i)
    if s[0] not in gl and s[3] not in sgl:
        k+=1
print(k)