03.11.2025

8 — 11202

# Полина составляет слова, переставляя буквы в слове АССЕМБЛЕР. Сколько слов может составить
# Полина, если известно, что сумма порядковых номеров гласных букв, в каждом из них, равна 9?
# Буквы нумеруются слева направо, начиная с единицы.

def f_gl(n):
    g = 'АЕ'
    mas = []
    for k in range(len(n)):
        if(n[k] in g):
            mas.append(k+1)
    return(sum(mas))

from itertools import *

fd = "АССЕМБЛЕР"

k = 0
sf = set()
for i in permutations(fd,9):

    s = "".join(i)
    if(f_gl(s)==9):
        print(s)
        sf.add(s)
print(len(sf))