02.11.2025

8 — 8553

# Все шестибуквенные слова, в составе которых могут быть только русские буквы
# Н, О, Р, М, А, Л, Ь, Е записаны в алфавитном порядке и пронумерованы начиная с 1.
# Ниже приведено начало списка
#     1. АААААА
#     2. АААААЕ
#     3. АААААЛ
#     4. АААААМ
#     5. АААААН
#     6. АААААО
#     7. АААААР
#     8. АААААЬ
# Определите сколько слов находится между первым словом начинающимся на «НОРМ» и
# словом «НЕНОРМ» (не включая эти слова)
from itertools import *

s = "АЕЛМНОРЬ"

answerCount = 1
for i in product(s, repeat = 6):
    temp = "".join(i)
    if (temp[:4:] == "НОРМ"):
        print(temp, answerCount)
    if (temp[:6:] == "НЕНОРМ"):
        print(temp, answerCount)
    answerCount += 1
print(answerCount)
print(154817 - 137588 - 1)