02.11.2025

Решение задачи ОГЭ при помощи массива

(№ 1041) Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 3. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – максимальное число, оканчивающееся на 3. 


e = []
a = int(input())
for i in range(a):
    b = int(input())
    e.append(b)
m=-30000

for i in range(a):
    if e[i]%10==3:
        if a[i]>m:
            m=a[i]
print(m)