03.11.2025

Пример решения задачи ОГЭ с использованием массива

# Напишите программу, которая в последовательности
# натуральных чисел определяет количество чисел,
# кратных 3 и оканчивающихся на 2. Программа получает
# на вход целые числа, количество введённых чисел неизвестно,
# последовательность чисел заканчивается числом 0 (0 – признак
# окончания ввода, не входит в последовательность).
# Количество чисел не превышает 1000. Введённые числа по модулю
# не превышают 30 000.

a=[] # массив в который поступают все числа
itog=[] # массив в который мы добавляем только числа подходящие по условию
n=1000
# добавление элементов в массив
for i in range(n):
    chislo=int(input())
    if chislo!=0:
        a.append(int(input()))
    else:
        break

print(a)
k=0
for i in range(len(a)):
    if a[i]%3==0 and a[i]%10==2:
        itog.append(a[i])

print(itog)
print(len(itog))
print(sum(itog))
print(max(itog))