02.11.2025

Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое двузначных чисел или сообщает, что таких чисел нет. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести среднее арифметическое двузначных чисел или вывести NO, если таких чисел в последовательности нет.

mas=[]
for i in range(1000):
    a=int(input())
    if a==0: break
    if a>9 and a<100:
        mas.append(a)

if sum(mas)!=0:
    print(sum(mas)/len(mas))
else:
    print('NO')