02.11.2025

Напишите программу, которая в последовательности натуральных чисел находит наименьшее число, кратное трём. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Гарантируется, что в последовательности есть хотя бы одно число, кратное трём.

masi = []

for i in range(1000):
    a = int(input())
    if a == 0:
        break
    if a % 3 == 0:
        masi.append(a)
print(min(masi))