02.11.2025

(№ 1037) Напишите программу, которая в последовательности целых чисел определяет количество чисел, кратных 5 или 9. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число: количество чисел, кратных 5 или 9.

k=0
for i in range(1000):
    a=int(input())
    if a==0:
        break
    if a%5==0 or a%9==0:
        k+=1
print(k)