02.11.2025

315- 12. На вход приведённой программы поступает строка, состоящая из 1 и следующими за ней n нулями (n – натуральное двузначное число). Определите, сколько существует значений n, при которых длина получившейся строки будет являться простым числом.

def checkProst(num):
    for i in range(2, int(num**0.5) + 1):
        if num % i == 0:
            return False
    return True

answer = 0
for n in range(10, 100):
    s = '1' + '0' * n
    while '10' in s:
        if '10' in s:
            s = s.replace('10', '001', 1)
        if '1' in s:
            s = s.replace('1', '01', 1)
    dlina = len(s)
    if checkProst(dlina):
        answer += 1
print(answer)