02.11.2025

Поляков 16-31. Определите наименьшее значение n, при котором значение F(n), будет больше числа 320. Запишите в ответе сначала найденное значение n, а затем через пробел – соответствующее значение F(n).

def F(n):
  if n>0: 
    return n%10*F(n//10)
  else: return 1

for x in range(1, 100000):
    if F(x) > 320:
        print(x, F(x))
        break