02.11.2025

Типовой пример решения задания 23 (9844)

# А. Вычесть 1
# В. Вычесть 3
# С. Найти целую часть от деления на 2
#
# Программа для исполнителя — это последовательность команд.
# Сколько существует программ, для которых при исходном числе 19 результатом является число 3,
# при этом траектория вычислений не содержит числа 7 и содержит 10?

def F(a,b):
    if a<b or a==7: return 0
    if a==b: return 1
    if a>b:  return F(a-1,b)+F(a-3,b)+F(a//2,b)

print(F(19,10)*F(10,3))