02.11.2025

Поляков. Раздел 5, задача №59

#     59) Автомат получает на вход четырёхзначное число. По этому числу
#     строится новое число по следующим правилам.
# 1. Складываются первая и вторая, а также третья и четвёртая цифры исходного числа.
# 2. Полученные два числа записываются друг за другом в порядке возрастания
#     (без разделителей).
# Пример. Исходное число: 3165. Суммы: 3 + 1 = 4; 6 + 5 = 11. Результат: 411.
# Укажите максимальное число, в результате обработки которого, автомат выдаст число 912.

for n in range(1000,9999+1):
    s=str(n)
    s1=s[0]
    s2=s[1]
    s3=s[2]
    s4=s[3]
    one=int(s1)+int(s2)
    two=int(s3)+int(s4)
    # print(one,two)
    mas=[one,two]
    # print(mas)
    mas=sorted(mas)
    # print(mas)
    s=str(mas[0])+str(mas[1])
    # print(s)

    if int(s)==912:
        print(n)