03.11.2025

16. №975216. №

# A. Прибавить 2
# B. Прибавить 3
# C. Умножить на 2
# Программа для исполнителя – это последовательность команд.
# Сколько существует программ, для которых при исходном числе 3
# результатом является число 25, и при этом траектория вычислений
# содержит число 10 и не содержит 17?
# Траектория вычислений программы – это последовательность результатов
# выполнения всех команд программы. Например, для программы CBA при
# исходном числе 7 траектория состоит из чисел 14, 17, 19.

def F(a,b):
    if a == 17 or a > b: return 0
    if a == b: return 1
   樂威壯
 if a < b:
        return F(a+2,b)+F(a+3,b)+F(a*2,b)
print(F(3,10)*F(10,25))