02.11.2025

компегэ 17 — 11949

# В файле содержится последовательность целых чисел. Элементы
# последовательности могут принимать целые значения от –100 000 до 100 000
# включительно. Определите количество четвёрок элементов последовательности,
# в которых или только одно из чисел или все четыре числа являются двузначным,
# а сумма элементов четвёрки не меньше максимального элемента последовательности,
# оканчивающегося на 68.
# В ответе запишите количество найденных четвёрок чисел, затем максимальную из
# сумм элементов таких четвёрок.
fileOpen = open('17_11949.txt')
mas = list(map(int, fileOpen.readlines()))
lenMas = len(mas)
maxMax = -100001
maxMaxMax = -321233
k2 = 0
for i in range(0, lenMas):
    if abs(mas[i]) % 100 == 68 and mas[i] > maxMax:
        maxMax = mas[i]
#maxMax is 95968
def is2(n):
    if 101 > abs(n) > 9:
        return True
    return False

for i in range(0, lenMas - 4):
    k = 0
    if is2(mas[i]):
        k += 1
    if is2(mas[i+1]):
        k += 1
    if is2(mas[i+2]):
        k += 1
    if is2(mas[i+3]):
        k += 1

    if k == 1 or k == 4:
        if (mas[i] + mas[i+1] + mas[i+2] + mas[i+3]) >= maxMax:
            k2 += 1
            if (mas[i] + mas[i+1] + mas[i+2] + mas[i+3]) > maxMaxMax:
                maxMaxMax = (mas[i] + mas[i+1] + mas[i+2] + mas[i+3])
print(k2, maxMaxMax)