02.11.2025

компегэ 17 — 3738

#В файле содержится последовательность натуральных чисел. Элементы последовательности могут принимать целые значения, по модулю не превосходящие 10 000 включительно. Определите количество чисел этой последовательности таких, что предыдущее и следующее число для них имеют одинаковую сумму цифр. В ответе запишите количество найденных чисел, затем самую часто встречающуюся сумму разрядов среди найденных чисел. В данной задаче под парой подразумевается два идущих подряд элемента последовательности.

fileOpen = open('17_3738.txt')
mas = list(map(int, fileOpen.readlines()))
def sumNum(s):
    s=str(s)
    summ=0
    for i in s:
        summ+=int(i)
    return summ


k = 0
ned = list()
for i in range(1,len(mas)-1):
    if sumNum(mas[i-1]) == sumNum(mas[i+1]):
        k += 1
        ned.append(sumNum(mas[i]))
ned = sorted(ned)
c = 1
maxC = 0
for j in range(len(ned)-1):
    if ned[j] == ned[j+1]:
        c += 1
    else:
        if c > maxC:
            maxC,num = c,ned[j]
        c = 1
print(k,num)