02.11.2025

Поляков егэ 5 — 278

    278) На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом.
1. Вычисляется сумма S1 всех нечётных цифр десятичной записи числа N. Если нечётных цифр нет, сумма S1 считается равной 0.
2. Вычисляется сумма S2 всех цифр десятичной записи числа N, стоящих на позициях с нечётными номерами. Позиции нумеруются слева направо, начиная с 1. 
3. Вычисляется результат R как модуль разности S1 и S2.
Пример: Дано число N = 4321. Сумма нечётных цифр S1 = 3 + 1 = 4. Сумма цифр в позициях с нечётными номерами S2 = 4 + 2 = 6. Результат работы алгоритма R = 6 – 4 = 2.
Укажите наименьшее число, в результате обработки которого по данному алгоритму получится число 31.

for n in range(0,10000000):
    b=0
    k=0
    n=str(n)
    for i in n:
        if int(i)%2==1:
            b+=int(i)

    for i in range(0,len(n),2):
        k+=int(n[i])

    l= abs(b-k)
    if l ==31:
        print (n)