02.11.2025

Поляков егэ 5 — 265

    265) Алгоритм получает на вход натуральное число N > 1 и строит по нему новое число R следующим образом:
1) Если исходное число кратно 3, оно делится на 3, иначе из него вычитается 1.
2) Если полученное на предыдущем шаге число кратно 7, оно делится на 7, иначе из него вычитается 1.
3) Если полученное на предыдущем шаге число кратно 11, оно делится на 11, иначе из него вычитается 1.
4) Число, полученное на шаге 3, считается результатом работы алгоритма.
Сколько существует различных натуральных чисел N, при обработке которых получится R = 6?

k=0
for a in range(0,10000):
    if a %3==0:
        a=a//3
    else:
        a=a-1

    if a %7==0:
        a=a//7
    else:
        a=a-1

    if a %11==0:
        a=a//11
    else:
        a=a-1
    if a==6:
        k+=1
print(k)