02.11.2025

Поляков 14-344

# 344 Значение выражения 3431515 – 6∙491520 + 5∙491510 – 3∙71530 – 1550 записали в
# системе счисления с основанием 7. Определите количество значащих нулей в этой
# записи.

n=343**1515 - 6*49**1520 + 5*49**1510 - 3*7**1530 - 1550
print(n)
k=0
while n>0:
    ost=n%7
    n=n//7
    if ost==0:
        k+=1
print(k)