02.11.2025

Поляков 14-321

Значение выражения 372 + 6·350 – 7·326 + 2·315 + 155 записали в системе счисления с основанием 9. Сколько различных цифр содержится в этой записи?


n=3**72 + 6*3**50 - 7*3**26 + 2*3**15 + 155
s=""
while n>0:
    ost=n%9
    n=n//9
    s+=str(ost)
print(s)
k=0
for i in range(10):
    if str(i) in s:
        k+=1
print(k)