02.11.2025

Поляков 17 — 370

#      Определите количество пар элементов последовательности, в которых
# – только одно число четырёхзначное;
# – сумма квадратов элементов пары делится нацело на минимальное трёхзначное число в последовательности,
#      оканчивающееся на 3.
#     В ответе запишите сначала количество найденных пар, затем минимальную из
#      сумм квадратов элементов таких пар.

z=10000000000
file = open("17-370.txt")
mas = list(map(int,file.readlines())) # создается массив из значений файла и кадый элемент массива переводится в число
for i in range(len(mas)):
    if 99<abs(mas[i])<1000 and abs(mas[i])%10==3:
        if mas[i]<z:
            z=mas[i]
print(z)
minim=100000000
count=0
for i in range(len(mas)-1):
    # Это счетчик для того чтобы определить только один элемент удовлетворяющему условию
    k=0
    if 999<abs(mas[i])<10000:
        k+=1
    if 999<abs(mas[i+1])<10000:
        k+=1
    #-------------------------------------------------------
    if k==1:
        if abs(mas[i]*mas[i]+mas[i+1]*mas[i+1])%z==0:
            count+=1
            if (mas[i]*mas[i]+mas[i+1]*mas[i+1])<minim:
                minim=(mas[i]*mas[i]+mas[i+1]*mas[i+1])
print(count,minim)