03.11.2025

Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число  — максимальное число, кратное 5

m=-100000
n=int(input("введите число "))
for i in range(n):
    a=int(input("а:  "))
    if a%5==0:
        if a>m:
            m=a
print(m)

Добавить комментарий