03.11.2025

Поляков раздел 14 №214

'''214)	Значение арифметического выражения: 36**17 + 6**15 - 9 записали в системе счисления
с основанием 6. Сколько цифр «5» в этой записи? '''

n=36**17 + 6**15 - 9
k=0
while n>0:
    ost=n%6
    n=n//6
    if ost==5:
        k+=1
print(k)

Добавить комментарий