02.11.2025

Поляков р17 №117

# 117)	(П. Волгин) Рассматривается множество целых чисел, принадлежащих числовому
# отрезку [100; 555555], которые удовлетворяют следующим условиям:
# а) Число в восьмеричной записи оканчивается на 66 или на 7.
# б) Число делится на 12 или не делится на 15.
# Найдите количество таких чисел и квадрат минимального из них. В ответе запишите сначала
# количество, а затем квадрат минимального числа.
kolvo = 0
minim = 10**10
for i in range(100, 555555+1):
    k1 = i % 8
    k2 = i // 8 % 8
    if i % 8 == 7 or (k1 == 6 and k2 == 6):
        if i % 12 == 0 or i % 15 != 0:
            kolvo +=1
            if i < minim:
                minim = i
print(kolvo, minim**2)

Добавить комментарий