02.11.2025

Поляков ЕГЭ раздел 17 №18

# 18)	Рассматривается множество целых чисел, принадлежащих отрезку [980; 5320], которые делятся на 4 или
# на 5 и не делятся на 11, 17, 19 и 23. Найдите количество таких чисел и минимальное из них.
#     В ответе запишите два числа через пробел: сначала количество, затем минимальное число.
k=0
minim=1000000000
for i in range(980, 5320 + 1):
    if ((i % 4 == 0) or (i % 5 == 0)) and (i % 11 != 0) and (i % 17 != 0) and (i % 19 != 0) and (i % 23 != 0):
        k+=1
        if i<minim:
            minim=i
print(k,minim)

Добавить комментарий