02.11.2025

18) Рассматривается множество целых чисел, принадлежащих отрезку [980; 5320], которые делятся на 4 или на 5 и не делятся на 11, 17, 19 и 23. Найдите количество таких чисел и минимальное и максимальное из них. В ответе запишите два числа через пробел: сначала количество, затем минимальное число.

k=0
minim=10000
maxim=-10000
for a in range(980,5320+1):
    if (a%4==0 or a%5==0) and a%11!=0 and a%17!=0 and a%19!=0 and a%23!=0:
        k+=1
        if a<minim:
            minim=a
        if a>maxim:
            maxim=a
print(k,minim,maxim)
    

Добавить комментарий